for those of you having trouble as WPA2 client

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
akula169
Posts: 16
Joined: Tue Feb 16, 2010 2:16 pm

for those of you having trouble as WPA2 client

Post by akula169 » Tue Feb 16, 2010 2:22 pm

{EDIT} I previously thought this was the fix to my problem, I was wrong... please read the next post {/EDIT}

I futzed with my setup for hours before I figured out that single quotes around the key are pretty much required, at least in my case...

Before I noticed this, it was quite bewildering, as iwconfig showed the AP's MAC address as associated, but wl0 could never get a DHCP offer.

Here's what my config looks like now:

Code: Select all

config wifi-device  wl0
	option type     broadcom
	option channel  1
	
	# REMOVE THIS LINE TO ENABLE WIFI:
#	option disabled 1

config wifi-iface
	option device   wl0
	option network	wan
	option mode     sta
	option ssid     MySSID
	option encryption psk2
	option key	'MyWPA2Key'

Last edited by akula169 on Tue Feb 16, 2010 4:30 pm, edited 1 time in total.

akula169
Posts: 16
Joined: Tue Feb 16, 2010 2:16 pm

Re: for those of you having trouble as WPA2 client

Post by akula169 » Tue Feb 16, 2010 3:32 pm

OK, so scratch that. My wireless was working for a minute... until I rebooted.

Now its broken again. Not sure what changed.

akula169
Posts: 16
Joined: Tue Feb 16, 2010 2:16 pm

Re: for those of you having trouble as WPA2 client

Post by akula169 » Tue Feb 16, 2010 4:14 pm

OK, so I dropped my AP down to WPA Personal from WPA2 Personal

Now it works with "option encryption psk"

Now... I'm wondering why WPA2 doesn't want to work with my router... anyone else having success with WPA2 client configs? I'd really rather not have to downgrade to WPA just to support my asus client connection.

jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: for those of you having trouble as WPA2 client

Post by jeroen94704 » Wed Feb 17, 2010 1:13 am

It is a known issue with OpenWrt that WPA2 does not work in client mode. I have no idea what the status of this issue is, and if/when it will be resolved, but for now, if you want to use an OpenWrt box as a wireless client, you are forced to drop to WPA.

Note that with a key of the proper length (AT LEAST more than 20-25 characters), this is no less secure.

akula169
Posts: 16
Joined: Tue Feb 16, 2010 2:16 pm

Re: for those of you having trouble as WPA2 client

Post by akula169 » Wed Feb 17, 2010 1:19 am

Thanks for the clarification about the known issue.

I'm by no means a linux noob, but my experience with OpenWRT is now all of about 16 hours old...

jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: for those of you having trouble as WPA2 client

Post by jeroen94704 » Wed Feb 17, 2010 1:24 am

OpenWRT rules, but the focus is definitely on a specific application (routers). Many things outside that narrow scope tend to require a bit more fiddling to get working, and that includes stuff like getting it to work as a client, USB sound etc.

akula169
Posts: 16
Joined: Tue Feb 16, 2010 2:16 pm

Re: for those of you having trouble as WPA2 client

Post by akula169 » Wed Feb 17, 2010 1:31 am

jeroen94704 wrote:OpenWRT rules
Indeed. A robust embedded development platform with ethernet hub, wireless, serial console and USB for less than $35? I'll be buying a handful of these 502gu's! I'm already dreaming up new applications for the hardware...

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: for those of you having trouble as WPA2 client

Post by mightyohm » Fri Nov 12, 2010 6:34 pm

Does anyone know if any of the more recent OpenWrt releases support wpa2-aes?

Post Reply