Example config files (look here if you are having problems)

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
User avatar
mightyohm
Site Admin
Posts: 1005
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Example config files (look here if you are having problems)

Post by mightyohm » Fri Mar 11, 2011 11:07 am

Originally posted here:
http://www.mightyohm.com/forum/viewtopic.php?f=2&t=275

Here are the config files I am using, for reference:

/etc/config/wireless

Code: Select all

config wifi-device  wl0
	option type     broadcom
	option channel  5

	# REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface
	option device   wl0
	option network	wan
	option mode     sta
	option ssid     MYSSID 
	option encryption wep
	option key MYWEPKEY

/etc/config/network

Code: Select all

#### VLAN configuration 
config switch eth0
	option vlan0	"1 2 3 4 5*"
	option vlan1	"0 5"


#### Loopback configuration
config interface loopback
	option ifname	"lo"
	option proto	static
	option ipaddr	127.0.0.1
	option netmask	255.0.0.0


#### LAN configuration
config interface lan
	#option type 	bridge
	option ifname	"eth0.0"
	option proto	static
	option ipaddr	192.168.1.1
	option netmask	255.255.255.0


#### WAN configuration
config interface	wan
	option ifname	"eth0.1"
	option proto	dhcp
/etc/config/firewall

Code: Select all

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT 
	option forward		REJECT

config zone
	option name		lan
	option input	ACCEPT 
	option output	ACCEPT 
	option forward	REJECT

config zone
	option name		wan
	option input	ACCEPT
	option output	ACCEPT 
	option forward	REJECT
	option masq		1 

config forwarding 
	option src      lan
	option dest     wan


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT 

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT 

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80 
#	option proto		tcp

# include a file with users custom iptables rules
#config include
#	option path /etc/firewall.user


### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT 

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

Nurek_bagieNNy
Posts: 4
Joined: Wed Sep 05, 2012 12:10 am
Location: PL

Re: Example config files (look here if you are having probl

Post by Nurek_bagieNNy » Sat Sep 22, 2012 5:35 am

content of /etc/init.d/mpd would be very useful :)

User avatar
mightyohm
Site Admin
Posts: 1005
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Example config files (look here if you are having probl

Post by mightyohm » Sat Sep 22, 2012 10:42 pm

This is /etc/init.d/mpd:

Code: Select all

#!/bin/sh /etc/rc.common
# Copyright (C) 2007 OpenWrt.org
START=93

start() {
	#create mpd directories
	md=`grep music_directory /etc/mpd.conf | cut -d "\"" -f 2 | sed "s/~/\/root/g"`
	if [ ! -d $md ]; then
		mkdir -p $md
	fi
	pld=`grep playlist_directory /etc/mpd.conf | cut -d "\"" -f 2 | sed "s/~/\/root/g"`
	if [ ! -d $pld ]; then
		mkdir -p $pld
	fi
	#create mpd db
        /usr/bin/mpd --stdout --create-db
	
	#optional export for mpc
        #export MPD_HOST=127.0.0.1
	
	#start mpd
        /usr/bin/mpd
	
	#generate playlist and start to play
        /usr/bin/mpc listall | /usr/bin/mpc add -
        /usr/bin/mpc play
	/usr/bin/mpc repeat	
}

stop() {
        killall mpd
}
						

cgchris99
Posts: 13
Joined: Tue Apr 11, 2017 7:53 am

Re: Example config files (look here if you are having problems)

Post by cgchris99 » Tue Apr 18, 2017 3:22 pm

config wifi-device wl0

Is that code w10 or wl0. Is that #1 or letter L?

User avatar
mightyohm
Site Admin
Posts: 1005
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Example config files (look here if you are having problems)

Post by mightyohm » Tue Apr 18, 2017 5:06 pm

lowercase letter 'L'

wl0

Post Reply