Creative Tactic Alpha USB sound card doesn't work

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
velja
Posts: 4
Joined: Wed Aug 10, 2016 7:56 am

Creative Tactic Alpha USB sound card doesn't work

Postby velja » Wed Aug 10, 2016 8:03 am

Hi,
My first post and the problem. I configure ASUS wl-520gU for wifi radio but this sound cart can't give any tone. Do I miss something? Here is partial log from serial port:


SB USB20H init

SB COREREV: 2

SB USB20H resetting

USB20H fcr: 0x64

USB20H shim cr: 0x8f7

usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6

usb-ohci.c: usb-00:03.0, PCI device 14e4:471a

usb.c: new USB bus registered, assigned bus number 1

hub.c: USB hub found

hub.c: 2 ports detected

usb.c: registered new driver audio

audio.c: v1.0.0:USB Audio Class driver

hub.c: new USB device 00:03.0-1, assigned address 2

usbaudio: device 2 audiocontrol interface 0 has 1 input and 1 output AudioStreaming interfaces

usbaudio: device 2 interface 2 altsetting 1 channels 1 framesize 2 configured

usbaudio: valid input sample rate 44100

usbaudio: device 2 interface 2 altsetting 1: format 0x00000010 sratelo 44100 sratehi 44100 attributes 0x00

usbaudio: device 2 interface 1 altsetting 0 does not have an endpoint

usbaudio: device 2 interface 1 altsetting 1 channels 2 framesize 2 configured

usbaudio: valid output sample rate 44100

usbaudio: device 2 interface 1 altsetting 1: format 0x01000010 sratelo 44100 sratehi 44100 attributes 0x00

usbaudio: device 2 interface 1 altsetting 2 channels 2 framesize 3 configured

usbaudio: valid output sample rate 44100

usbaudio: device 2 interface 1 altsetting 2: format 0x01000800 sratelo 44100 sratehi 44100 attributes 0x00

usbaudio: registered dsp 14,3

usbaudio: registered mixer 14,0

usbaudio: registered mixer 14,16

velja
Posts: 4
Joined: Wed Aug 10, 2016 7:56 am

Re: Creative Tactic Alpha USB sound card doesn't work

Postby velja » Wed Aug 10, 2016 8:16 pm

So, I open USB device and found Conexant CX20562 chip inside. Wheh I installed opkg package for USB I install only kmod-usb-audio and kmod-usb-ohci. When I stat mpc play I get message that it play but nothing come out. I done everything as it described in Part5 of instruction and get all response as it written but no sound. This sound card work when I connect to laptop/


Return to “Wifi Radio Project / Hacking the Asus WL-520gU”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest