Help Hack WL 520GU

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.

Re: Help Hack WL 520GU

Postby zordlyon » Fri Dec 03, 2010 4:35 pm

The restoration tool is simply...

You click on black reset button of the router, and plug the energy, and then the power led go blink slowly...
The router is in safe mode...
Plug the LAN cable on PC-Router...
you launch the restoration tool on a pc or virtual machine with windows...

and select the image what you want upload.. then upload the image and the router its flashed...

simple and great...

is the guide...the DD-WRT with me work fine...
http://www.society9.com/an-easy-guide-t ... sus-520gu/

But mightyohm you can put here the best solution .trx link for my project please?

Thanks...
zordlyon
 
Posts: 12
Joined: Fri Dec 03, 2010 12:30 pm

Re: Help Hack WL 520GU

Postby zordlyon » Fri Dec 10, 2010 3:15 pm

Hi people,

Today i'm installed for the first time the OpenWrt sucessfully...

But...there is always a but... : :roll:

When i'm configuring the router i changed the wireless and network configurations, but the LED of the Wireless dont come up... :x

The changes are here:

Wireless:
Code: Select all
config wifi-device  wl0
        option type     broadcom
        option channel  2

        # REMOVE THIS LINE TO ENABLE WIFI:


config wifi-iface
        option device   wl0
        option network  lan
        option mode     sta #configura o router para conectar a net
        option ssid        MyNetwork #O SSID da rede
        option encryption wep #o modo de encriptacao da vossa rede
        option key 12345 # adicionem a password da vossa rede
~
~
~
~
~
~
~
~
~
- etc/config/wireless 1/14 7%


NetWork:
Code: Select all
#### VLAN configuration
config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan1    "0 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    dhcp
        #option ipaddr  192.168.1.1
        #option netmask 255.255.255.0


- /etc/config/network 1/27 3%


/etc/resolv.conf
Code: Select all
nameserver 127.0.0.1
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
- /etc/resolv.conf 1/1 100%


What wrong??
I'm in a MAC plataform, i have the airport turned off...

But the LED of the router dont come up...

Thanks everyone...
zordlyon
 
Posts: 12
Joined: Fri Dec 03, 2010 12:30 pm

Re: Help Hack WL 520GU

Postby mightyohm » Mon Dec 20, 2010 11:01 am

This is becoming a FAQ these days - I think I will need to write something about this and put it on the wiki soon!

If the air light is not on, the router is not connecting to your home wireless network. Usually this is because the channel is set incorrectly in /etc/config/wireless, or because the encryption is not set correctly. Try double-checking that you have the right channel number, and maybe turn off WEP and see if you can get the router to connect that way first, before re-enabling it again.
User avatar
mightyohm
Site Admin
 
Posts: 834
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA

Re: Help Hack WL 520GU

Postby janw » Mon Dec 20, 2010 11:09 am

I used an Xbee adaptor to do the serial communication. It has a 3.3V level.
janw
 
Posts: 10
Joined: Sun Nov 28, 2010 1:46 pm

Re: Help Hack WL 520GU

Postby zordlyon » Mon Jan 17, 2011 2:53 am

mightyohm wrote:This is becoming a FAQ these days - I think I will need to write something about this and put it on the wiki soon!

If the air light is not on, the router is not connecting to your home wireless network. Usually this is because the channel is set incorrectly in /etc/config/wireless, or because the encryption is not set correctly. Try double-checking that you have the right channel number, and maybe turn off WEP and see if you can get the router to connect that way first, before re-enabling it again.


But for enable the wireless in the router i need connect the router to my home wireless network? Because i just need the wireless connected to my computer for comunication between PC - Router - Arduino.

Thanks...
zordlyon
 
Posts: 12
Joined: Fri Dec 03, 2010 12:30 pm

Re: Help Hack WL 520GU

Postby mightyohm » Mon Jan 17, 2011 9:13 am

No, you do not, but you need to configure the router differently than you would if you were connecting to an existing wireless network.

You can read about the configuration options here:
http://wiki.openwrt.org/doc/uci/wireless

You'll want to set "option mode ap" (I think) and you might need to make some minor changes to /etc/config/network depending on how you want to assign IP addresses on your point to point network.

Also, needless to say you'll have to use a different SSID than your home network, and your PC won't be able to connect to both the router and your home wireless at the same time (unless you have two wifi cards?)
User avatar
mightyohm
Site Admin
 
Posts: 834
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA

Re: Help Hack WL 520GU

Postby zordlyon » Mon Jan 17, 2011 9:22 am

Yeah i know i cant connect to both network's at the same time...

Thanks for the link, i will try..

If anyone have the wireless configurations of this router in AP mode i aprecciate...

Thanks one more time...
zordlyon
 
Posts: 12
Joined: Fri Dec 03, 2010 12:30 pm

Re: Help Hack WL 520GU

Postby zordlyon » Tue Aug 02, 2011 7:17 am

Hi, after very long time without touch on this project, i'm back again with a question...

I have my router in AP Mode and i can access them via wireless, but now i need access them via ssh/telnet to use it..

But when i try "ssh root@<ip address>" show me a message "Connection refused"...

I trying to resolve this for 3 hours and nothing until now...

What is wrong for i cant access via ssh?

Any help?

Thanks a lot,
André.
zordlyon
 
Posts: 12
Joined: Fri Dec 03, 2010 12:30 pm

Previous

Return to Wifi Radio Project / Hacking the Asus WL-520gU

Who is online

Users browsing this forum: No registered users and 3 guests