Stuck on Part 4 - No Air Light

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
cldela0
Posts: 7
Joined: Wed Jan 13, 2010 6:16 pm

Stuck on Part 4 - No Air Light

Post by cldela0 »

I am very new to this and am following the build step by step. I have OpenWRT loaded and can talk to the router through the serial connection using ZTerm. I have set both the wireless and network settings identical to the instructions. Problem is that I never get the AIR light to come on. I have been through the forum and tried many of the suggestions to no end. My best guess is that the problem has something to do with my wep key. I have a 2wire router from Windstream that has a 10 digit default wep key written on the barcode. I have tried putting that number in as well as adding 0x to the front of it and still nothing. At this point how would I set up the router if I turned off the encryption (no security)? That would help me narrow the issue down to my wep key or something else. Any help would be greatly appreciated. This looks like a great project, but I can't get the router talking.

Thanks
Chris
User avatar
mightyohm
Site Admin
Posts: 1064
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Stuck on Part 4 - No Air Light

Post by mightyohm »

To disable encryption, edit the file /etc/config/wireless.

Edit the "option encryption" line to set encryption to "none" and comment out the wep key, as shown below:

Code: Select all

config wifi-iface
	option device   wl0
	option network	wan
	option mode     sta
	option ssid    <your SSID> 
	option encryption none
	#option key <your wep key>
cldela0
Posts: 7
Joined: Wed Jan 13, 2010 6:16 pm

Re: Stuck on Part 4 - No Air Light

Post by cldela0 »

Still no luck. Does the fact that my router assigns address 192.168.254.100-200 play a part? I thought dhcp would cover that. Really at a loss. What info can I provide to help troubleshoot the issue?
cldela0
Posts: 7
Joined: Wed Jan 13, 2010 6:16 pm

Re: Stuck on Part 4 - No Air Light

Post by cldela0 »

Here is the code for both wireless and network as well as a screen shot showing my wireless settings if they will help.

Code: Select all

config wifi-device w10
        option type     broadcom
        option channel  4

        # REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface
        option device   wl0
        option network  wan
        option mode    sta
        option ssid    WIN_874
        option encryption wep
        option key     4119627022 #this is the sample key from the manual



#### VLAN configuration
config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan1    "0 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        #option type    bridge
        option ifname   "eth0.0"
        option proto  static
        option ipaddr  192.168.1.1
        option netmask  255.255.255.0
Attachments
routersettings
routersettings
User avatar
mightyohm
Site Admin
Posts: 1064
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Stuck on Part 4 - No Air Light

Post by mightyohm »

Try changing the key in /etc/config/wireless from 4119627022 to F58C850E. Save the file, reboot, and see if the router connects.

The IP address should be fine.
cldela0
Posts: 7
Joined: Wed Jan 13, 2010 6:16 pm

Re: Stuck on Part 4 - No Air Light

Post by cldela0 »

I just stumbled on the error - a typo in the following line "config wifi-device w10". At some point I had mistakenly put a "1" in wlo instead of an "l'. I found the issue when researching the use of "iwlist wl0 scan" to test if any networks were even being picked up. Thanks for all the help.

Chris
User avatar
mightyohm
Site Admin
Posts: 1064
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Stuck on Part 4 - No Air Light

Post by mightyohm »

Good to hear you have the problem under control now. Sorry I wasn't able to find the problem for you, I wasn't looking in the right place. :D
cldela0
Posts: 7
Joined: Wed Jan 13, 2010 6:16 pm

Re: Stuck on Part 4 - No Air Light

Post by cldela0 »

Thanks for giving your time to help novices! Next time a will be sure to watch out for those similar letters :D
richms
Posts: 21
Joined: Fri Jul 24, 2009 3:25 am

Re: Stuck on Part 4 - No Air Light

Post by richms »

Watch the channel too. That had me cursing and swearing for ages about it not working.
Post Reply