Geiger Counter working but not a peep on the serial port

Support forum for the mightyohm.com Geiger Counter.
http://mightyohm.com/geiger
Post Reply
ebaugh
Posts: 6
Joined: Mon Nov 18, 2019 11:41 am

Geiger Counter working but not a peep on the serial port

Post by ebaugh »

Got a question:

I have had my Geiger counter working for a while, but hadn't checked the serial port. (In terms of working I hear it beep, led flashes at a rate that seems appropriate). Button silences.

As I've been working on projects during the lock down, I got back to the Geiger counter... was thinking of converting it to 5v...and figuring out a way to get it on-line... as well as needing to get a case. Got the case (via Adafruit) ... arrived today and really does make it look nicer!

Before I did any conversions or anything I had seen this site (https://syncchannel.blogspot.com/2016/0 ... tyohm.html). Since I have both of those two parts, and that this would allow me to both have a nice display AND feed data from it to my weewx based weather site, I started on this. Got code and that all working on the Geiger counter.... but no data coming from the serial pins.

So, after getting the case, I changed out the tube (I had some tubes that I had gotten (shorter ones) since I wasn't all that sure how good the previous tube I had was... so moved the mounting end). And since I got the case, changed out the button to be the one with the longer shaft so it can be triggered from above the case. And went back over the soldering (since I had assembled the kit, and had sourced the parts and flashed them, etc.) Touched up anything that looked even the slightest bit potentially off.

Then brought it back upstairs, hoping that had resolved the serial output. Behavior the same before and after the tube change, button change, and solder touchup.

So I took out my TTL-232R-3v3 Serial to USB cable... which I use on a bunch of other development boards... and hooked it up to my Mac.
IMG_2249.jpeg
Nada. No output at all. Nothing. (that's a picture of the cable I used)

It's working now with the shorter tube the same as it did with the longer tube..... So nothing fundamental seems off.
I just don't get any serial data.

But the unit seems to be working based on what I expect as normal background radiation.
IMG_2250.jpeg
I actually got a picture of it when it blinked. RIght now, I know i don't have the pin connected to this for the feather (so I don't expect it right this sec to show counts on that.) I had just disconnected the serial cable to take the picture. Power is coming from the Feather (based on the link above). Tested, it's 3.3V so that and the behavior seems to indicate the basic functionality is working.

So, that's as best of a description as I can give of the current state. Don't know what should be the next step.....

Thoughts? Pointers?

User avatar
mightyohm
Site Admin
Posts: 1019
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Geiger Counter working but not a peep on the serial port

Post by mightyohm »

You mentioned in email that you flashed the MCU yourself. If the fuse bytes are not set, the baud rate might be way off and that will cause problems.
Other ideas - low batteries may cause problems, try fresh alkaline AA's.
Solder joints - sounds like you checked this.
Serial cable connected backwards. If you are using an FTDI cable, the cable color code should match the grn and blk silk on the PCB. (But it might be good to check anyway. Pin1, labeled blk, is ground.)
Ceramic resonator wrong frequency or not working properly.
Sometimes when inserting the MCU into a socket, the pins will fold under instead of making it into the contact pins. I've seen this a couple times.
Do you have a logic analyzer or oscilloscope?

ebaugh
Posts: 6
Joined: Mon Nov 18, 2019 11:41 am

Re: Geiger Counter working but not a peep on the serial port

Post by ebaugh »

1) Verified that cable is right. It's the same colors as you had indicated in some other posts. Black to pin 1, Green to end. That's been checked at last three times :-)

2) Power -- check the picture, you can see that it's getting 3v via the Adafruit Feather. (see link for project that adds display and feather to allow you to send data, etc. So that should be good/sufficient.

3) Solder joints -- yup.

4) I used machined pin sockets. They tend to prevent the fold under. That looks good (I can send additional pictures, but that seems good)

5) If the Ceramic resonator isn't working properly would it still trigger?

I have a logic analyzer that I recently got. So can try to puzzle it out... sadly not scope yet. I do need to get one at some time (need one at work as well... but that's another story.

So it could be the fuses in the MCU. How could I check that? Should I go back thru the flashing process?

User avatar
mightyohm
Site Admin
Posts: 1019
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Geiger Counter working but not a peep on the serial port

Post by mightyohm »

If the ceramic resonator is off-frequency or the fuse bytes are set incorrectly, the kit may still appear to work fine, though the pitch of the beeper will be wrong and the serial port will not work (the baud rate will be wrong).

How did you flash the MCU?

If you used the Makefile included with the source code, you need to execute "make flash" followed by "make fuse".
If you can do this again and post the results of these commands, that would be helpful.

ebaugh
Posts: 6
Joined: Mon Nov 18, 2019 11:41 am

Re: Geiger Counter working but not a peep on the serial port

Post by ebaugh »

Well, after a bunch of work projects (and other "honey-do" projects :-) )
I got back to trying to reflash.

I flashed it again (this time on my local mac) and that went ok.

Then I did "make fuse". That DEFINITELY was what was wrong.
The beep sound changed SIGNIFICANTLY so I though right away, Ah! that's what he meant.

Grabbed the USB Serial cabled, and vola! I have serial data!

Thanks so much for all your help, thanks for a great project and sorry it took so long to provide a final answer.
(I never like to leave threads unfinished...)

Thanks again
Earl

User avatar
mightyohm
Site Admin
Posts: 1019
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Geiger Counter working but not a peep on the serial port

Post by mightyohm »

Earl,

Sorry for the late reply.
Glad you got it sorted out. Enjoy your kit!

Post Reply