Page 1 of 1

Geiger Counter not working

Posted: Tue Feb 12, 2019 2:34 pm
by pepsiplease69
I recently purchased a geiger counter kit from Adafruit and put it together but it doesn't seem to work properly. I'm not getting any signals.

I checked all the solder points and they seem okay.

I tried to short the TP1 pad with the ground pin in the pulse J6, i'm able to get a signal both on piezo as well as LED.

When I measure the voltage between TP2 and ground pin, I'm barely registering 2.7 volts. This led me to believe that the Q3 transistor was needing replacement. I unsoldered it and installed a similar 2N222 ( transistor in its place.

I'm still registering 2.7 volts on the TP2.

I made sure all the pins on the 555 timer were correct, nothing was bent, and the solder points were good.

Here are the readings on all of the pins in the U1 timer (555)

1: 0V
2: 0V
3: 2.9V
4: 2.9V
5: 1.9V
6: 0V
7: 0V
8: 2.9V

I tried to short across the two clips ( + and - ) of the GM tube, nothing happens when I do that.

What could be the source of my problem?

Will it be okay to use 2N222 transistor for Q3, it seems from wiki page, that they are similar.

Is there any other thing I can measure voltages for, in order to figure out where the problem lies?


Re: Geiger Counter not working

Posted: Tue Feb 12, 2019 2:36 pm
by pepsiplease69
Oh and by the way, I do have a radioactive object which should generate a signal (aside from the background noise).

I am using a Pentax SMC Takumar 50mm lens as the radiation source.

When I put its rear element next to the GM tube, nothing happens.


Re: Geiger Counter not working

Posted: Tue Feb 12, 2019 9:28 pm
by mightyohm
Can you post a high res photo of the top and bottom of the PCB?

Check the direction of D2 and make sure it matches the silkscreen on the PCB. Also check the solder connections around R6, D2, C3, R9, and U1.

Re: Geiger Counter not working

Posted: Fri Feb 15, 2019 1:07 pm
by pepsiplease69
Direction of D2 seems correct. I have also re-checked the solder points for R6, D2, R9, C3, and U1. There seems to be a good amount of solder on the contacts.

Please see images.

Re: Geiger Counter not working

Posted: Sat Feb 16, 2019 12:18 pm
by mightyohm
First, confirm that the voltage from pin 3 to ground is still 2.9V, and the voltage from pin 2 to ground is 0V. This is the issue - if pin 3 is stuck high, then pin 2 should be high as well. Measure the voltage across R5, D2, C3, and R9. Those voltages will help us troubleshoot what is going on.

It's hard to tell from your photo, but some of the solder joints look slightly suspect. I can't see the lead poking through the solder, so it's hard to tell if the lead is there and soldered. Make sure that the leads of the 8 pin socket are actually going through the PCB and none of them are folded under the socket. I'd touch up all of the circled solder joints - some of them look like the iron may not have been touching the lead and the solder pad long enough - these are the joints that don't have a nice "hershey kiss" shape. It can also be caused by too much solder. I'd use solder wick or a solder sucker, remove the excess solder, and then solder them again.

You can also try replacing D2 - it's a common small signal diode. 1N914 and 1N4148 are both good replacements. If that fails to fix the problem I'd probably replace the 555. Make sure to use a CMOS TLC555 and not an ordinary 555 timer.

Re: Geiger Counter not working

Posted: Sat Feb 16, 2019 1:22 pm
by pepsiplease69
Hello Jeff,
Problem has been solved! Thanks for your support.

I checked the voltages again on the 555 timer pins 3 and 2, it was 3V and 0V respectively.

I also checked the voltages across R5, D2, C3, and R9 as per your instructions. All of them were showing 0V across.

So I started working on the 555 timer, to wick away the solder as much as possible from the contacts. I removed the IC from the housing and pried off the housing from the PCB (couldn't remove all the solder). I managed to destroy the housing in the process.

Pin 3 on the housing was indeed bent under and not coming through the hole, so that was clearly the culprit.

I then inserted the 555 timer directly into the PCB and it seemed that the footprint matched (without the housing in the middle). So I soldered ALL of the pins securely to the PCB. I was careful not to subject the pins of the 555 timer directly to too much heat, but instead heat the pad and let the solder flow over the pad and the pin as well.

When I inserted the GM tube and the batteries again and powered it up, it started working.

The TP2 pad is now getting 270V which is the expected value.

My Pentax SMC Takumar 50mm lens is indeed radioactive.

Thanks again and please consider this issue as resolved.

Re: Geiger Counter not working

Posted: Sat Feb 16, 2019 2:31 pm
by mightyohm
Glad you got it working! Let me know if there is anything else I can help you with.