Anybody get the 520gU wireless (B43) to work with 2.6 kernel

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby lostmyshape » Wed Nov 16, 2011 8:39 am

IggyCeltic, thanks for the help, but it looks to me like you're actually using the 2.4 kernel. Somebody correct me if I'm wrong but the "broadcom" driver (in the wireless config: "option 'type' 'broadcom'") is from the brcm-2.4. From what I understand from wiki.openwrt.org, the 2.6 kernel uses the b43 driver built into mac80211.

The good news is that I have pulseaudio working pretty well. There are some stutters and disconnects, but quality is better than I ever got with MPD on the WL-520gu. Of course this is wired to my main router. I'd love to get wireless working on trunk with the 2.6 kernel.

Maybe it's security? My router logs seem to say that the 520gu is connecting, and ifconfig shows me an IP address, but I can't ping anything out from the 520gu or ping the box at that address. So weird.
lostmyshape
 
Posts: 6
Joined: Thu Mar 31, 2011 11:16 am

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby dext3r » Thu Dec 01, 2011 10:10 pm

I have been able to get wireless working on backfire RC5 r27608 without any fixes or anything, just edit the network/wireless config files.

the odd thing though, is i have one 520gu running solid for a couple weeks now, but another is getting random wifi radio fuckups, (thats a technical term) causing the wireless to crash "hard balls" (another technical term)

i tried using backfire RC6 and bleeding edge trunk (attitude adjustment) and I couldn't get wireless to work at all. used the name network/wireless config files as the working RC5 install. im getting an error related to wpa_supplicant authentication, not sure why. (sorry, dont know the exact error off the top of my head and cant get to the router right now)

im gonna try RC5 again tomorrow ,we'll see if it works.
dext3r
 
Posts: 10
Joined: Wed Nov 17, 2010 11:32 pm

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby dext3r » Thu Dec 01, 2011 10:11 pm

lostmyshape wrote:IggyCeltic, thanks for the help, but it looks to me like you're actually using the 2.4 kernel. Somebody correct me if I'm wrong but the "broadcom" driver (in the wireless config: "option 'type' 'broadcom'") is from the brcm-2.4. From what I understand from wiki.openwrt.org, the 2.6 kernel uses the b43 driver built into mac80211.

The good news is that I have pulseaudio working pretty well. There are some stutters and disconnects, but quality is better than I ever got with MPD on the WL-520gu. Of course this is wired to my main router. I'd love to get wireless working on trunk with the 2.6 kernel.

Maybe it's security? My router logs seem to say that the 520gu is connecting, and ifconfig shows me an IP address, but I can't ping anything out from the 520gu or ping the box at that address. So weird.


do you have the firewall running?
dext3r
 
Posts: 10
Joined: Wed Nov 17, 2010 11:32 pm

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby dext3r » Sun Dec 04, 2011 11:32 pm

OK got it connected with Attitude Adjustment, bleeding edge.

Code: Select all
BusyBox v1.19.3 (2011-12-01 00:51:01 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r29366) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:/# uname -a
Linux OpenWrt 3.0.9 #14 Sun Dec 4 23:15:21 CST 2011 mips GNU/Linux
root@OpenWrt:/# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth0.0    no wireless extensions.

eth0.1    no wireless extensions.

br-lan    no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"James Quall" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:1D:73:B4:83:F0   
          Bit Rate=24 Mb/s   Tx-Power=20 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-8 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:7   Missed beacon:0

root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 20:CF:30:87:F1:0A 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:170 errors:0 dropped:75 overruns:0 frame:0
          TX packets:489 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:41566 (40.5 KiB)  TX bytes:196993 (192.3 KiB)

eth0      Link encap:Ethernet  HWaddr 20:CF:30:87:F1:0A 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:569 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1710 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:154434 (150.8 KiB)  TX bytes:694796 (678.5 KiB)
          Interrupt:4

eth0.0    Link encap:Ethernet  HWaddr 20:CF:30:87:F1:0A 
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:562 errors:0 dropped:0 overruns:0 frame:0
          TX packets:703 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:141282 (137.9 KiB)  TX bytes:271810 (265.4 KiB)

eth0.1    Link encap:Ethernet  HWaddr 20:CF:30:87:F1:0A 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1002 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:403806 (394.3 KiB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:21672 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21672 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1476123 (1.4 MiB)  TX bytes:1476123 (1.4 MiB)

wlan0     Link encap:Ethernet  HWaddr 20:CF:30:87:F1:0A 
          inet addr:10.10.1.139  Bcast:10.10.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:750 errors:0 dropped:0 overruns:0 frame:0
          TX packets:345 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:108953 (106.3 KiB)  TX bytes:39431 (38.5 KiB)

root@OpenWrt:/#


I'm using the b43 firmware version 410, which is what ive got running on my working RC5 setup.
You have to manually select this version from the configuration menu ("make menuconfig")
I have no idea if the newer versions help/hurt stability.

Code: Select all
[  394.948000] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)


There seems to be some kind of bug with the generation of configuration files. OpenWRT reads the junk from /etc/config/wireless and builds a config file for wpa_supplicant on the fly. I manually created a wpa_supplicant config file and started it up. Then to get an IP from DHCP, ran 'udhcpc -i wlan0'.
It worked, but its different than backfire RC5, where br-lan is the interface with the IP address, but it seems to work fine.

Anybody have a good way to stress test the stability of this? Maybe looped HTTP downloads or something?
dext3r
 
Posts: 10
Joined: Wed Nov 17, 2010 11:32 pm

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby djmasterg » Fri Mar 09, 2012 4:59 pm

dext3r

Any progress with 2.6 kernel? I have a wl 520gu, and want to try 2.6 kernel. Im not sure where to start, or what built to install. The only reason I want to try 2.6 is that I need aac playback on my asus.
djmasterg
 
Posts: 17
Joined: Fri Mar 09, 2012 8:46 am
Location: Glasgow, UK

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby mightyohm » Wed Mar 14, 2012 10:46 am

I would head over to openwrt.org and grab the latest release or maybe check out the trunk repository. This is definitely something you will need to play around with, I don't think there is a quick/easy "out of the box" setup that is going to work for you, but maybe things have changed in the past year or so...
User avatar
mightyohm
Site Admin
 
Posts: 839
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA

Re: Anybody get the 520gU wireless (B43) to work with 2.6 ke

Postby gerben » Thu Mar 15, 2012 9:01 am

from http://wiki.openwrt.org/toh/asus/wl520gu
Warning! Kernel support for the radio is broken when using the 2.6 kernel (b43 driver) via the brcm47xx target in the original Backfire (10.03) release! OpenWrt doesn't enable the radio out of the box. If you enable it, processes get killed and the box becomes unusable. The issue is discussed in https://dev.openwrt.org/ticket/6907


But I don't think you need the 2.6 kernel. Newer versions of MPD can run just fine on 2.4, if I'm correct.

PS. I think it is time for you to just get your hand dirty. Just flash the router with the newers OpenWrt with 2.4 kernel and see if you get AAC working. There isn't much you can do wrong (especially with an Asus). And if you find out you'll need another version, just reflash it. ;)
User avatar
gerben
 
Posts: 164
Joined: Sat Oct 16, 2010 8:41 am
Location: Netherlands

Previous

Return to Wifi Radio Project / Hacking the Asus WL-520gU

Who is online

Users browsing this forum: Google [Bot] and 3 guests